aboutsummaryrefslogtreecommitdiffstats
path: root/conf.d/project/json.d/CMakeLists.txt
diff options
context:
space:
mode:
authorRomain Forlot <romain.forlot@iot.bzh>2017-08-21 10:23:18 +0200
committerRomain Forlot <romain.forlot@iot.bzh>2017-08-21 10:23:18 +0200
commit88d0b8c02eaaac8843f184e379fc5a19250295e5 (patch)
tree4893d2b5cb0fdbddf0357ebd7d32009e73856cec /conf.d/project/json.d/CMakeLists.txt
parentba709f088f5a4718b7096003ab19083af4681155 (diff)
parentd51d083be8e34000cd00ce979445eacb45a16e97 (diff)
Merge branch 'fulup-dev'
Change-Id: I7dc6859767ac5919cf383e33bd2cf3a98698d9b4
Diffstat (limited to 'conf.d/project/json.d/CMakeLists.txt')
-rw-r--r--conf.d/project/json.d/CMakeLists.txt32
1 files changed, 32 insertions, 0 deletions
diff --git a/conf.d/project/json.d/CMakeLists.txt b/conf.d/project/json.d/CMakeLists.txt
new file mode 100644
index 0000000..8070997
--- /dev/null
+++ b/conf.d/project/json.d/CMakeLists.txt
@@ -0,0 +1,32 @@
+###########################################################################
+# Copyright 2017 IoT.bzh
+#
+# author: Fulup Ar Foll <fulup@iot.bzh>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+
+##################################################
+# Control Policy Config file
+##################################################
+PROJECT_TARGET_ADD(ctl-config.d)
+
+ file(GLOB XML_FILES "*.json")
+
+ add_input_files("${XML_FILES}")
+
+ SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
+ LABELS "DATA"
+ OUTPUT_NAME ${TARGET_NAME}
+ )