aboutsummaryrefslogtreecommitdiffstats
path: root/Common/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Common/CMakeLists.txt')
-rw-r--r--Common/CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/Common/CMakeLists.txt b/Common/CMakeLists.txt
new file mode 100644
index 0000000..79ee8ac
--- /dev/null
+++ b/Common/CMakeLists.txt
@@ -0,0 +1,31 @@
+###########################################################################
+# Copyright 2015, 2016, 2017 IoT.bzh
+#
+# author: Fulup Ar Foll <fulup@iot.bzh>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+PROJECT(audio-common C)
+
+INCLUDE_DIRECTORIES(${include_dirs})
+
+##################################################
+# AudioCommon is a local static Library
+##################################################
+ADD_LIBRARY(audiocommon STATIC AudioCommonLib.c)
+SET_TARGET_PROPERTIES(audiocommon PROPERTIES OUTPUT_NAME audiocommon)
+SET(link_libraries ${libefence_LIBRARIES} ${json-c_LIBRARIES})
+TARGET_LINK_LIBRARIES(audiocommon ${link_libraries})
+
+