aboutsummaryrefslogtreecommitdiffstats
path: root/HighLevel-afb/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'HighLevel-afb/CMakeLists.txt')
-rw-r--r--HighLevel-afb/CMakeLists.txt43
1 files changed, 0 insertions, 43 deletions
diff --git a/HighLevel-afb/CMakeLists.txt b/HighLevel-afb/CMakeLists.txt
deleted file mode 100644
index 9d7af4c..0000000
--- a/HighLevel-afb/CMakeLists.txt
+++ /dev/null
@@ -1,43 +0,0 @@
-###########################################################################
-# Copyright 2015, 2016, 2017 IoT.bzh
-#
-# author: Fulup Ar Foll <fulup@iot.bzh>
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-###########################################################################
-
-
-# Add target to project dependency list
-PROJECT_TARGET_ADD(audio)
-
- # Define project Targets
- ADD_LIBRARY(audio MODULE HighLevelApiConf.c HighLevelBinding.c)
-
- # Binder exposes a unique public entry point
- SET_TARGET_PROPERTIES(audio PROPERTIES
- PREFIX "afb-"
- LABELS "BINDING"
- LINK_FLAGS ${BINDINGS_LINK_FLAG}
- OUTPUT_NAME ${TARGET_NAME}
-
- )
-
- # Library dependencies (include updates automatically)
- TARGET_LINK_LIBRARIES(audio
- audio-inter
- ${link_libraries}
- )
-
- # installation directory
- INSTALL(TARGETS audio
- LIBRARY DESTINATION ${BINDINGS_INSTALL_DIR})