summaryrefslogtreecommitdiffstats
path: root/plugins/CMakeLists.txt
diff options
context:
space:
mode:
authorFulup Ar Foll <fulup@iot.bzh>2018-04-30 23:30:10 +0200
committerFulup Ar Foll <fulup@iot.bzh>2018-04-30 23:30:10 +0200
commit17edfc4c20cfd855d68e5b0ef044da2e7509f3f3 (patch)
treefe33046462ede30e6faaabbac82e1b75d49f28af /plugins/CMakeLists.txt
parent8372b87f2be8fe5b8655001e92572af4d96ddbf6 (diff)
On going effort, now load and support LUA+C plugin
Diffstat (limited to 'plugins/CMakeLists.txt')
-rw-r--r--plugins/CMakeLists.txt28
1 files changed, 5 insertions, 23 deletions
diff --git a/plugins/CMakeLists.txt b/plugins/CMakeLists.txt
index 644e359..28a0609 100644
--- a/plugins/CMakeLists.txt
+++ b/plugins/CMakeLists.txt
@@ -1,13 +1,13 @@
###########################################################################
# Copyright 2015, 2016, 2017 IoT.bzh
#
-# author: Romain Forlot <romain.forlot@iot.bzh>
+# author: Fulup Ar Foll <fulup@iot.bzh>
#
# Licensed under the Apache License, Version 2.0 (the "License");
# you may not use this file except in compliance with the License.
# You may obtain a copy of the License at
#
-# http://www.apache.org/licenses/LICENSE-2.0
+# http://www.apache.org/licenses/LICENSE-2.0
#
# Unless required by applicable law or agreed to in writing, software
# distributed under the License is distributed on an "AS IS" BASIS,
@@ -17,24 +17,6 @@
###########################################################################
-PROJECT_TARGET_ADD(alsa-router)
-
- # Define targets
- ADD_LIBRARY(${TARGET_NAME} MODULE ${TARGET_NAME}.c)
-
- # Alsa Plugin properties
- SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
- LABELS "PLUGIN"
- PREFIX ""
- SUFFIX ".ctlso"
- OUTPUT_NAME ${TARGET_NAME}
- )
-
- # Library dependencies (include updates automatically)
- TARGET_LINK_LIBRARIES(${TARGET_NAME}
- ${link_libraries}
- )
-
- target_include_directories(${TARGET_NAME}
- PRIVATE "../app-controller-submodule/ctl-lib"
- PRIVATE "../mixer-binding")
+# Include any directory not starting with _
+# -----------------------------------------------------
+PROJECT_SUBDIRS_ADD(${PROJECT_SRC_DIR_PATTERN})