summaryrefslogtreecommitdiffstats
path: root/clients/meson.build
diff options
context:
space:
mode:
authorMarius Vlad <marius.vlad@collabora.com>2020-09-16 17:22:24 +0300
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-09-30 13:43:12 +0000
commitbe8288cc5b127074fae6e2da052d6cd5cd623ae2 (patch)
tree5c6577281b56defb4b4df2fa7d2abe3dbdd67a74 /clients/meson.build
parent991714fc7f92aea3d07c7225247a821e3461027e (diff)
client/screenshooter: Client for taking screenshots
The client allows to take screenshots of all outputs, a specific output (making use of xdg_output_manager interface) or just listing outputs. Bug-AGL: SPEC-3580 Signed-off-by: Marius Vlad <marius.vlad@collabora.com> Change-Id: Idd60d4892adf4c2ea493477421b6e5623e0ca1f0
Diffstat (limited to 'clients/meson.build')
-rw-r--r--clients/meson.build40
1 files changed, 40 insertions, 0 deletions
diff --git a/clients/meson.build b/clients/meson.build
new file mode 100644
index 0000000..08b2c08
--- /dev/null
+++ b/clients/meson.build
@@ -0,0 +1,40 @@
+dep_wayland_client = dependency('wayland-client', version: '>= 1.17.0')
+
+clients = [
+{
+ 'basename': 'agl-screenshooter',
+ 'sources': [
+ 'screenshooter.c',
+ '../shared/file-util.c',
+ '../shared/os-compatibility.c',
+ '../shared/xalloc.c',
+ agl_screenshooter_client_protocol_h,
+ agl_screenshooter_protocol_c,
+ xdg_output_unstable_v1_client_protocol_h,
+ xdg_output_unstable_v1_protocol_c,
+ ],
+ 'deps_objs' : [ dep_wayland_client ],
+ 'deps': [ 'cairo' ],
+},
+]
+
+foreach t: clients
+ t_name = t.get('basename')
+ t_deps = t.get('deps_objs', [])
+
+ foreach xdep: t.get('deps', [])
+ dep = dependency(xdep, required: false)
+ if dep.found()
+ t_deps += dep
+ endif
+ endforeach
+
+ executable(
+ t_name, t.get('sources'),
+ include_directories: [ common_inc ],
+ dependencies: [ t_deps, libweston_dep ],
+ install: true,
+ )
+
+ message('Building client ' + t_name)
+endforeach