summaryrefslogtreecommitdiffstats
path: root/grpc-proxy/meson.build
diff options
context:
space:
mode:
authorMarius Vlad <marius.vlad@collabora.com>2022-10-25 13:06:41 +0300
committerMarius Vlad <marius.vlad@collabora.com>2022-12-13 12:31:18 +0200
commit59375972f5642b7ec5115fdecf4828f6af02f343 (patch)
tree14912e10b5894e0d3eef773ed3306f455352b9ec /grpc-proxy/meson.build
parent0b766cf978b8b100caecd4c61464e1a683685072 (diff)
grpc-proxy: Init gRPCsandbox/mvlad/grpc-async-cb
This brings in support for accessing agl-shell protocol indirectly by using a gRPC interface which bridges the communication between a particular client (the client issuing gRPC requests) and the AGL compositor which does that by re-using the same agl-shell protocol. In order to achieve that, and further more, to avoid having ifdefs code in the compositor and deal with threading, we instead resorted to using a helper client. On one side this helper implements the gRPC server API, and on the other, a wayland native client that implements the agl_shell interface. It uses the agl_shell_ext interface added previously to communicate with the compositor that it requires access to agl_shell interface as well. The helper expects that agl_shell interface was already bounded to another client before starting it so it waits until that happens and then it implements the protocol specification, for each interface. Launching the helper client automatically can be done by adding the following entry to the ini file: [shell-client-ext] command=/path/to/agl-shell-grpc-server The gRPC server implementation only handles the agl_shell interface until to this point, specifically, the activate_app request, and the events that were adedd with version 3 of the agl-shell protocol. Also the implementation uses the Reactor pattern, with Callback service that greatly simplifies the async version and avoids putting locks to to handle multiple clients. This should allow multiple clients being connected to the gRPC server and receive events / send requests. Bug-AGL: SPEC-4503 Signed-off-by: Marius Vlad <marius.vlad@collabora.com> Change-Id: Ie870da3caa138394d8dd30f9d22a5552d585d63a
Diffstat (limited to 'grpc-proxy/meson.build')
-rw-r--r--grpc-proxy/meson.build46
1 files changed, 46 insertions, 0 deletions
diff --git a/grpc-proxy/meson.build b/grpc-proxy/meson.build
new file mode 100644
index 0000000..3d7171b
--- /dev/null
+++ b/grpc-proxy/meson.build
@@ -0,0 +1,46 @@
+dep_wayland_client = dependency('wayland-client', version: '>= 1.17.0')
+
+grpcpp_reflection_dep = cxx.find_library('grpc++_reflection')
+protoc = find_program('protoc')
+grpc_cpp = find_program('grpc_cpp_plugin')
+
+protoc_gen = generator(protoc, \
+ output : ['@BASENAME@.pb.cc', '@BASENAME@.pb.h'],
+ arguments : ['--proto_path=@CURRENT_SOURCE_DIR@/',
+ '--cpp_out=@BUILD_DIR@',
+ '@INPUT@'])
+
+generated_protoc_sources = protoc_gen.process('agl_shell.proto')
+
+grpc_gen = generator(protoc, \
+ output : ['@BASENAME@.grpc.pb.cc', '@BASENAME@.grpc.pb.h'],
+ arguments : ['--proto_path=@CURRENT_SOURCE_DIR@/',
+ '--grpc_out=@BUILD_DIR@',
+ '--plugin=protoc-gen-grpc=' + grpc_cpp.path(),
+ '@INPUT@'])
+generated_grpc_sources = grpc_gen.process('agl_shell.proto')
+
+grpc_deps = [
+ dependency('protobuf'),
+ dependency('grpc'),
+ dependency('grpc++'),
+ grpcpp_reflection_dep,
+]
+
+srcs = [
+ 'main-grpc.cpp',
+ 'grpc-async-cb.cpp',
+ 'shell.cpp',
+ generated_protoc_sources,
+ generated_grpc_sources,
+ agl_shell_client_protocol_h,
+ agl_shell_protocol_c,
+]
+
+executable(
+ 'agl-shell-grpc-server', srcs,
+ include_directories: [ common_inc ],
+ dependencies: [ grpc_deps, dep_wayland_client, libweston_dep ],
+ install: true,
+ install_dir: dir_module_agl_compositor,
+)