summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorMarius Vlad <marius.vlad@collabora.com>2023-05-23 15:48:56 +0300
committerMarius Vlad <marius.vlad@collabora.com>2023-05-31 07:36:15 +0000
commit0ed8064b0de235fa21fb961f0a8789e11ad7f1a4 (patch)
tree318fd5d2a9ace1587ed5d038f3f0034ac258b348 /meson.build
parente0a1dcc5480872fcb1ddafcd8664ef1b92f9446b (diff)
compositor: Remove Waltham support
Waltham hasn't been used in a while, its support has been removed for some time, we've been deprecating it last release so it's time to remove it from the compositor as well. Bug-AGL: SPEC-4669 Signed-off-by: Marius Vlad <marius.vlad@collabora.com> Change-Id: Iaf1e467b1228051fd96cac424ac6781d67f9fefa
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build26
1 files changed, 0 insertions, 26 deletions
diff --git a/meson.build b/meson.build
index 388f785..2079fb1 100644
--- a/meson.build
+++ b/meson.build
@@ -64,25 +64,6 @@ foreach depname : depnames
endforeach
-# the transmitter plug-in requires waltham but we don't have a cflags or libs
-# for it so we add waltham depends here. Further more, the output is being
-# handled by remoting plug-in
-depnames_waltham = [
- 'waltham', 'waltham-transmitter',
-]
-
-deps_waltham = []
-foreach depname : depnames_waltham
- dep = dependency(depname, required: false)
- if dep.found()
- deps_waltham += dep
- else
- message('Waltham requires @0@ which was not found. '.format(depname))
- endif
-endforeach
-
-deps_waltham += deps_remoting
-
agl_shell_xml = files('protocol/agl-shell.xml')
agl_shell_desktop_xml = files('protocol/agl-shell-desktop.xml')
agl_screenshooter = files('protocol/agl-screenshooter.xml')
@@ -225,13 +206,6 @@ if deps_remoting.length() == depnames.length()
message('Found remoting depends, enabling remoting')
endif
-if deps_waltham.length() == depnames_waltham.length() + depnames.length() and not get_option('waltham')
- message('Found waltham depends, but waltham is deprecated')
-elif deps_waltham.length() == depnames_waltham.length() + depnames.length() and get_option('waltham')
- config_h.set('HAVE_WALTHAM', 1)
- message('Found waltham depends, enabling waltham')
-endif
-
if dep_libsmack.found()
config_h.set('HAVE_SMACK', 1)
deps_libweston += dep_libsmack