summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorMarius Vlad <marius.vlad@collabora.com>2023-05-08 19:20:25 +0300
committerMarius Vlad <marius.vlad@collabora.com>2023-06-21 12:03:41 +0300
commit8033c46081b93f19843d140e58b527af7abf7a4f (patch)
treeacfc3b46c6cc2e9aa47acf2e5aabaa0400a3c965 /meson.build
parentffdbb335ee72a5b5cba198800c5537b89d7755a0 (diff)
compositor: Add XWayland basic support
This allow starting up XWayland and the ability to display, albeit is incomplete, given that we have no way at this moment to make the window maximized, as we do with xdg-shell/native wayland applications. A further patch, together with libweston changes are needed to make this complete. For now this can provide us with initial smoke testing. Tested with basic X11 clients, including Unigine, which is the reason for having this the moment. Note that this at the moment compiled-out, requiring the pass -Dxwayland=true when building the compositor. Bug-AGL: SPEC-4782 Signed-off-by: Marius Vlad <marius.vlad@collabora.com> Change-Id: I87d2a852165cb3f03482bea1e04931bdd6d4c115
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 4d846d2..2f8b11f 100644
--- a/meson.build
+++ b/meson.build
@@ -205,6 +205,13 @@ if deps_remoting.length() == depnames.length()
message('Found remoting depends, enabling remoting')
endif
+if get_option('xwayland')
+ config_h.set('BUILD_XWAYLAND', '1')
+
+ srcs_agl_compositor += 'src/xwayland.c'
+ config_h.set_quoted('XSERVER_PATH', get_option('xwayland-path'))
+endif
+
dir_module_agl_compositor = join_paths(join_paths(prefix_path, get_option('libdir')), 'agl-compositor')
libexec_compositor = shared_library(