summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorMarius Vlad <marius.vlad@collabora.com>2021-04-20 15:06:15 +0300
committerMarius Vlad <marius.vlad@collabora.com>2021-04-20 15:52:53 +0300
commit0bef8700f21b9e7898f1785ee654d4669d0117b4 (patch)
treea90e201f784c6272c19c4b2445a404e18229aacc /meson.build
parent65361f9f797905679c6c58c58733036911d54f7e (diff)
This is follow-up to catch up with weston's way of loading the compositor instance. This is necessary because the test itself is capable of loading a specific compositor instance (and with, specific arguments). No functional changes whatsoever. Bug-AGL: SPEC-3889, SPEC-3880 Signed-off-by: Marius Vlad <marius.vlad@collabora.com> Change-Id: Iedb979156a73def4567927969ab9190c481ffbce
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build24
1 files changed, 20 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 82bb990..27fb2d0 100644
--- a/meson.build
+++ b/meson.build
@@ -158,8 +158,9 @@ deps_libweston = [
local_dep,
]
+
srcs_agl_compositor = [
- 'src/main.c',
+ 'src/compositor.c',
'src/desktop.c',
'src/layout.c',
'src/policy.c',
@@ -190,7 +191,6 @@ elif policy_to_install == 'rba'
message('Installing rba policy')
endif
-
# From meson documentation:
# In order to look for headers in a specific directory you can use args :
# '-I/extra/include/dir, but this should only be used in exceptional cases for
@@ -237,12 +237,28 @@ if dep_libsmack.found()
deps_libweston += dep_libsmack
endif
+
+libexec_compositor = shared_library(
+ 'exec_compositor',
+ sources: srcs_agl_compositor,
+ dependencies: deps_libweston,
+ install: true,
+ version: '0.0.0',
+ soversion: 0
+)
+
+dep_libexec_compositor = declare_dependency(
+ link_with: libexec_compositor,
+ include_directories: [ include_directories('.') ],
+ dependencies: deps_libweston,
+)
+
configure_file(output: 'config.h', configuration: config_h)
exe_agl_compositor = executable(
'agl-compositor',
- srcs_agl_compositor,
- dependencies: deps_libweston,
+ 'src/main.c',
+ dependencies: dep_libexec_compositor,
install: true
)