summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorMarius Vlad <marius.vlad@collabora.com>2020-06-10 13:50:55 +0300
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-06-26 15:00:49 +0000
commitea317303ac428ea6c49b30f97d01ff9c92af1268 (patch)
treee2ae172dfeee14720a76e207f95fe17ef95a04de /meson.build
parentbbf173123cdd4c64330fbf77631a9ae120e7d09f (diff)
policy-default: Use libsmack to check client label
Use the client file descriptor to find out the SMACK label of that client. Enforces homescreen to bind to agl_shell and launcher and alexa-viewer to bind to the agl-shell-desktop interface. Allows access to agl_shell_desktop to tbtnavi and hvac as those contain example code on use it for moving it to other outputs. Bug-AGL: SPEC-3396 Signed-off-by: Marius Vlad <marius.vlad@collabora.com> Change-Id: I1a1abf2d2786624ffa484b6577de17f5010d5ac6
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index bc65c1c..ad996e8 100644
--- a/meson.build
+++ b/meson.build
@@ -41,6 +41,7 @@ foreach func: optional_libc_funcs
endforeach
dep_libsystemd = dependency('libsystemd', required: false)
+dep_libsmack = dependency('libsmack', required: false)
dep_scanner = dependency('wayland-scanner', native: true)
prog_scanner = find_program(dep_scanner.get_pkgconfig_variable('wayland_scanner'))
dep_wp = dependency('wayland-protocols', version: '>= 1.18')
@@ -180,6 +181,11 @@ if deps_remoting.length() == depnames.length()
message('Found remoting depends, enabling remoting')
endif
+if dep_libsmack.found()
+ config_h.set('HAVE_SMACK', 1)
+ deps_libweston += dep_libsmack
+endif
+
configure_file(output: 'config.h', configuration: config_h)
exe_agl_compositor = executable(