summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorMarius Vlad <marius.vlad@collabora.com>2020-06-10 16:23:14 +0300
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-06-26 15:00:49 +0000
commit03f51daf2fcf82f4f3de6371aa6fb8a58555d5d2 (patch)
tree9d91df006f99933d0c6f9b762801d60147590339 /meson.build
parentea317303ac428ea6c49b30f97d01ff9c92af1268 (diff)
policy: Add a deny-all policy as an example
Note this will deny any binding to the private extensions by default, if the compositor is not built with SMACK support. Defines a potential lists of applications permitted to create/display/activate surfaces/applications. Bug-AGL: SPEC-3413 Signed-off-by: Marius Vlad <marius.vlad@collabora.com> Change-Id: I2dbd3b3ef0d519fde7952f97e0303ff2b151aaa0
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build11
1 files changed, 10 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index ad996e8..9dd9673 100644
--- a/meson.build
+++ b/meson.build
@@ -139,7 +139,6 @@ srcs_agl_compositor = [
'src/desktop.c',
'src/layout.c',
'src/policy.c',
- 'src/policy-default.c',
'src/shell.c',
'shared/option-parser.c',
'shared/os-compatibility.c',
@@ -150,6 +149,16 @@ srcs_agl_compositor = [
xdg_shell_protocol_c,
]
+policy_to_install = get_option('policy-default')
+if policy_to_install == 'auto' or policy_to_install == 'allow-all'
+ srcs_agl_compositor += 'src/policy-default.c'
+ message('Installing allow all policy')
+elif policy_to_install == 'deny-all'
+ srcs_agl_compositor += 'src/policy-deny.c'
+ message('Installing deny all policy')
+endif
+
+
# From meson documentation:
# In order to look for headers in a specific directory you can use args :
# '-I/extra/include/dir, but this should only be used in exceptional cases for