summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorMarius Vlad <marius.vlad@collabora.com>2023-01-11 14:48:06 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-01-29 22:26:50 +0000
commitce8dd33f3762e0ec44927b70059fb2721338e8bf (patch)
treee5b4feaabe90f310b9c87995a7206c396dfec4ef /meson.build
parent6fd11a88c4d3c82e33b6086d4783ce172e1a2695 (diff)
meson: Deprecate waltham and inform users of that
Waltham isn't really used, this is a step forward removing support for it. For now just add an configuration option if users still want to use it. Bug-AGL: SPEC-4670 Signed-off-by: Marius Vlad <marius.vlad@collabora.com> Change-Id: I5ec900ef075717b438ef9e41167ad4833b2a8b87
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index cab7574..bdec8fd 100644
--- a/meson.build
+++ b/meson.build
@@ -239,7 +239,9 @@ if deps_remoting.length() == depnames.length()
message('Found remoting depends, enabling remoting')
endif
-if deps_waltham.length() == depnames_waltham.length() + depnames.length()
+if deps_waltham.length() == depnames_waltham.length() + depnames.length() and not get_option('waltham')
+ message('Found waltham depends, but waltham is deprecated')
+elif deps_waltham.length() == depnames_waltham.length() + depnames.length() and get_option('waltham')
config_h.set('HAVE_WALTHAM', 1)
message('Found waltham depends, enabling waltham')
endif