summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorMarius Vlad <marius.vlad@collabora.com>2020-02-17 16:42:27 +0200
committerMarius Vlad <marius.vlad@collabora.com>2020-03-06 18:16:05 +0200
commita35a7f2e5cc20bd40ece91918e753c709e2ee10b (patch)
treec360bef05b5cd721c1529e9b60cc4468023d138a /meson.build
parentdbba1adda7fd9aaaa46263d8c878132a523327e4 (diff)
protocol: Add agl-shell-desktop protocol
Protocol intented for use by regular XDG application which want to tell the compositor to activate another application. This mimics the activate_app request from agl-shell, and assumes the application is already started. Bug-AGL: SPEC-3252 Signed-off-by: Marius Vlad <marius.vlad@collabora.com> Change-Id: I1f7bd1d8d2f7d8f1eedf710aef1bf1046846f9be
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 37eb26a..aa69218 100644
--- a/meson.build
+++ b/meson.build
@@ -50,6 +50,7 @@ xdg_shell_xml = join_paths(dir_wp_base, 'stable', 'xdg-shell', 'xdg-shell.xml')
protocols = [
{ 'name': 'agl-shell', 'source': 'internal' },
+ { 'name': 'agl-shell-desktop', 'source': 'internal' },
{ 'name': 'xdg-shell', 'source': 'wp-stable' },
]
@@ -122,7 +123,9 @@ srcs_agl_compositor = [
'shared/option-parser.c',
'shared/os-compatibility.c',
agl_shell_server_protocol_h,
+ agl_shell_desktop_server_protocol_h,
agl_shell_protocol_c,
+ agl_shell_desktop_protocol_c,
xdg_shell_protocol_c,
]