summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorNaoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>2024-05-03 14:29:13 +0300
committerNaoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>2024-12-29 17:21:00 +0900
commit2218de5d4581843f229f2327900d9e11ff65c738 (patch)
treef114f3b742a81b6993c63d4d23633c4ccba55d05 /meson.build
parent0824eb521f8e26e4c0f143ec7850d45c4b2f675b (diff)
Add drm-lease support
Add an option to use a DRM lease instead of a DRM device as the video output. This will allow agl-compositor to operate alongside other applications output via a DRM lease. The original patch developed by Damian Hobson-Garcia <dhobsong@igel.co.jp>. This patch based on his work. On the other hand, it cause some build error in case of disabling a drm lease build option. This patch improve to fix build error in case of disabling a drm lease build option. Bug-AGL: SPEC-4889 Change-Id: Idd76d574ee9cfd72f97657dddaa40d904fa2788b Signed-off-by: Naoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 215b5ac..8dd852a 100644
--- a/meson.build
+++ b/meson.build
@@ -138,6 +138,7 @@ srcs_agl_compositor = [
'src/policy.c',
'src/shell.c',
'src/input.c',
+ 'src/drm-lease.c',
'shared/option-parser.c',
'shared/os-compatibility.c',
'shared/process-util.c',
@@ -159,6 +160,11 @@ elif policy_to_install == 'rba'
message('Installing rba policy')
endif
+if get_option('drm-lease')
+ deps_libweston += dependency('libdlmclient')
+ config_h.set('HAVE_DRM_LEASE', '1')
+endif
+
# From meson documentation:
# In order to look for headers in a specific directory you can use args :
# '-I/extra/include/dir, but this should only be used in exceptional cases for