summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorMarius Vlad <marius.vlad@collabora.com>2020-09-17 00:24:31 +0300
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-09-30 13:43:12 +0000
commit3ba840cd3a5a2fa1966b01ef286de0347e64aa46 (patch)
treeb5916f33b400b73b561e7c8d4ace407b03a3a98d /meson.build
parentbe8288cc5b127074fae6e2da052d6cd5cd623ae2 (diff)
input: Add basic seat handling
This allows for basic input handling, to better customize how we handle out seat capabilities to the client. One useful outcome of this is the fact that we re-advertise to the client that in some situations there might not be a pointer available. That should let the client know as to avoid creating a pointer surface. Bug-AGL: SPEC-3591 Signed-off-by: Marius Vlad <marius.vlad@collabora.com> Change-Id: I4624a956264e9fa12a86da005944e9b426dde10a
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 6809579..ab4f086 100644
--- a/meson.build
+++ b/meson.build
@@ -144,6 +144,7 @@ srcs_agl_compositor = [
'src/policy.c',
'src/shell.c',
'src/screenshooter.c',
+ 'src/input.c',
'shared/option-parser.c',
'shared/os-compatibility.c',
agl_shell_server_protocol_h,