summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorMarius Vlad <marius.vlad@collabora.com>2020-09-15 18:12:24 +0300
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-09-30 13:43:12 +0000
commit991714fc7f92aea3d07c7225247a821e3461027e (patch)
tree9054e78451203614aaf190c1a9a30e3d2bc49be1 /meson.build
parent1f888f2050ac50ec8c1750ff4f0e2c485936d7ed (diff)
screenshooter: Add agl-screenshooter protocol
Just like weston, we add a private protocol. Underneath we make use of the weston renderer to get a hold of the pixels and transfer them to a user-supplied buffer. This only brings up the server side implementation of the protocol. Bug-AGL: SPEC-3580 Signed-off-by: Marius Vlad <marius.vlad@collabora.com> Change-Id: I02a07ad5eb492ef2ecad74efb34d1453ebcbedc0
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 9dd9673..4299d58 100644
--- a/meson.build
+++ b/meson.build
@@ -65,11 +65,13 @@ endforeach
agl_shell_xml = files('protocol/agl-shell.xml')
agl_shell_desktop_xml = files('protocol/agl-shell-desktop.xml')
+agl_screenshooter = files('protocol/agl-screenshooter.xml')
xdg_shell_xml = join_paths(dir_wp_base, 'stable', 'xdg-shell', 'xdg-shell.xml')
protocols = [
{ 'name': 'agl-shell', 'source': 'internal' },
{ 'name': 'agl-shell-desktop', 'source': 'internal' },
+ { 'name': 'agl-screenshooter', 'source': 'internal' },
{ 'name': 'xdg-shell', 'source': 'wp-stable' },
]
@@ -140,12 +142,15 @@ srcs_agl_compositor = [
'src/layout.c',
'src/policy.c',
'src/shell.c',
+ 'src/screenshooter.c',
'shared/option-parser.c',
'shared/os-compatibility.c',
agl_shell_server_protocol_h,
agl_shell_desktop_server_protocol_h,
+ agl_screenshooter_server_protocol_h,
agl_shell_protocol_c,
agl_shell_desktop_protocol_c,
+ agl_screenshooter_protocol_c,
xdg_shell_protocol_c,
]