summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorMarius Vlad <marius.vlad@collabora.com>2020-06-02 12:47:13 +0300
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-06-15 10:09:17 +0000
commitb3c4f205c94e55d574483160f5d38b0bfc7c1d16 (patch)
tree16acdc05906de3b5c8449090d721392f47a6df23 /meson.build
parent7af3d3760c29157282348648d893af285b7efb34 (diff)
main: Add the ability to load the remote plugin
Streaming to 'remote' outputs needs the remote-plugin library. We build it automatically if we determine that the gst dependencies are satisfied, otherwise we're using a stub version for it. Unfortunatelly, upstream doesn't provide necessary header for the remoting.h so we copy-paste directly. Will follow up with upstream to provide headers for the plugins. Bug-AGl: SPEC-3280 Signed-off-by: Marius Vlad <marius.vlad@collabora.com> Change-Id: Ide277b402c511ed075fa1c5aaaf7770b50359c35
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build21
1 files changed, 21 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 9040f48..bc65c1c 100644
--- a/meson.build
+++ b/meson.build
@@ -46,6 +46,22 @@ prog_scanner = find_program(dep_scanner.get_pkgconfig_variable('wayland_scanner'
dep_wp = dependency('wayland-protocols', version: '>= 1.18')
dir_wp_base = dep_wp.get_pkgconfig_variable('pkgdatadir')
+depnames = [
+ 'gstreamer-1.0', 'gstreamer-allocators-1.0',
+ 'gstreamer-app-1.0', 'gstreamer-video-1.0',
+ 'gobject-2.0', 'glib-2.0'
+]
+
+deps_remoting = []
+foreach depname : depnames
+ dep = dependency(depname, required: false)
+ if not dep.found()
+ message('Remoting requires @0@ which was not found. '.format(depname))
+ endif
+deps_remoting += dep
+endforeach
+
+
agl_shell_xml = files('protocol/agl-shell.xml')
agl_shell_desktop_xml = files('protocol/agl-shell-desktop.xml')
xdg_shell_xml = join_paths(dir_wp_base, 'stable', 'xdg-shell', 'xdg-shell.xml')
@@ -159,6 +175,11 @@ if dep_libsystemd.found()
message('Found systemd, enabling notify support')
endif
+if deps_remoting.length() == depnames.length()
+ config_h.set('HAVE_REMOTING', 1)
+ message('Found remoting depends, enabling remoting')
+endif
+
configure_file(output: 'config.h', configuration: config_h)
exe_agl_compositor = executable(