summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorMarius Vlad <marius.vlad@collabora.com>2020-09-16 17:22:24 +0300
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-09-30 13:43:12 +0000
commitbe8288cc5b127074fae6e2da052d6cd5cd623ae2 (patch)
tree5c6577281b56defb4b4df2fa7d2abe3dbdd67a74 /meson.build
parent991714fc7f92aea3d07c7225247a821e3461027e (diff)
client/screenshooter: Client for taking screenshots
The client allows to take screenshots of all outputs, a specific output (making use of xdg_output_manager interface) or just listing outputs. Bug-AGL: SPEC-3580 Signed-off-by: Marius Vlad <marius.vlad@collabora.com> Change-Id: Idd60d4892adf4c2ea493477421b6e5623e0ca1f0
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 4299d58..6809579 100644
--- a/meson.build
+++ b/meson.build
@@ -73,6 +73,7 @@ protocols = [
{ 'name': 'agl-shell-desktop', 'source': 'internal' },
{ 'name': 'agl-screenshooter', 'source': 'internal' },
{ 'name': 'xdg-shell', 'source': 'wp-stable' },
+ { 'name': 'xdg-output', 'source': 'unstable', 'version': 'v1' },
]
foreach proto: protocols
@@ -225,3 +226,6 @@ install_data(
[ agl_shell_xml, agl_shell_desktop_xml ],
install_dir: join_paths(dir_data, dir_data_agl_compositor)
)
+
+common_inc = [ include_directories('src'), include_directories('.') ]
+subdir('clients')