summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorMarius Vlad <marius.vlad@collabora.com>2020-02-01 01:52:32 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-02-10 18:43:51 +0000
commitca5e2aec22cb7bc54710fa8ac02b48e6a592f315 (patch)
tree6523e40a136f452a9ab68eb66240923290ced275 /meson.build
parented4a9b0d9c593777551af3145e27ea40aced3e31 (diff)
meson.build: Allow to build/install locally
The cflags from libweston6 already have a libweston6 prefix path, which is problematic when building locally as the compositor already uses 'libweston-6' as include directive. This only applies to situations where libweston-6 is not installed in system's path. Bug-AGL: SPEC-3150 Signed-off-by: Marius Vlad <marius.vlad@collabora.com> Change-Id: Ib545e727b455fd872da15447e0cd54fea999d294
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build13
1 files changed, 13 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index b7fd577..294d82f 100644
--- a/meson.build
+++ b/meson.build
@@ -88,10 +88,23 @@ foreach proto: protocols
endforeach
endforeach
+# libweston-6 pkg-config file already has 'libweston-6' as prefix but
+# agl-compositor uses 'libweston-6' also. This makes use of the prefix
+# path as to allow building and installing the compositor locally
+prefix_path = get_option('prefix')
+message('prefix_path ' + prefix_path)
+if not prefix_path.contains('/usr')
+ additional_include_dir = include_directories(prefix_path + '/' + 'include')
+ local_dep = declare_dependency(include_directories: additional_include_dir)
+else
+ local_dep = []
+endif
+
deps_libweston = [
dependency('wayland-server'),
dependency('libweston-6'),
dependency('libweston-desktop-6'),
+ local_dep,
]
srcs_agl_compositor = [