summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorAnusha Gugale <external.agogale@jp.adit-jv.com>2020-12-17 15:08:36 +0530
committerMarius Vlad <marius.vlad@collabora.com>2021-01-12 11:01:21 +0000
commite1e8c07e202ffccc7b56f8f116a2ef1624028f91 (patch)
tree4f77d49747f380ced89fce12ef14d01b20c0505a /meson.build
parent838efcb58cbe08ca31dedbda9a140f4968dd7d29 (diff)
Added rba policy implementationkoi_10.92.0koi/10.92.010.92.0
- Added rba-policy option in meson file - Created new rba adapter file to call rba interfaces from librba - All the application from Homescreen will be allowed to display through rba policy as its added in RBAModel.json Bug-AGL: SPEC-3738 Signed-off-by: Anusha Gugale <external.agogale@jp.adit-jv.com> Change-Id: Iffd4ac16d9abe768476d025556cbe98a31553288
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 7 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index e0ec2ae..11ee2c1 100644
--- a/meson.build
+++ b/meson.build
@@ -1,5 +1,5 @@
project('agl-compositor',
- 'c',
+ 'c','cpp',
version: '0.0.18',
default_options: [
'warning_level=3',
@@ -15,6 +15,8 @@ libweston_version = 'libweston-8'
pkgconfig = import('pkgconfig')
cc = meson.get_compiler('c')
+cxx = meson.get_compiler('cpp')
+
add_project_arguments(
cc.get_supported_arguments([
'-Wno-unused-parameter',
@@ -182,6 +184,10 @@ if policy_to_install == 'auto' or policy_to_install == 'allow-all'
elif policy_to_install == 'deny-all'
srcs_agl_compositor += 'src/policy-deny.c'
message('Installing deny all policy')
+elif policy_to_install == 'rba'
+ srcs_agl_compositor += ['src/policy-rba.c', 'src/rba_adapter.cpp']
+ deps_libweston += dependency('librba')
+ message('Installing rba policy')
endif