summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorMarius Vlad <marius.vlad@collabora.com>2020-01-06 18:22:38 +0200
committerMarius Vlad <marius.vlad@collabora.com>2020-01-30 01:03:27 +0200
commitffd00ab3a05351bac2124e5eba8a66f20a3b62da (patch)
tree9de9264ff2d185f83bd0c87fc1193d4254326f1e /meson.build
parent219a513fd959b86517fc5c48cb8deda3830262ef (diff)
ivi-compositor: Add systemd notify message
Notifies systemd that agl-compositor has been started. Re-uses most of the weston bits. Bug-AGL: SPEC-3119 Change-Id: I1a0b41093b2ce68dd4a64475af18d27338712c3d Signed-off-by: Marius Vlad <marius.vlad@collabora.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build14
1 files changed, 14 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 08548f8..c338ee6 100644
--- a/meson.build
+++ b/meson.build
@@ -9,6 +9,8 @@ project('agl-compositor',
license: 'MIT/Expat',
)
+config_h = configuration_data()
+
cc = meson.get_compiler('c')
add_project_arguments(
cc.get_supported_arguments([
@@ -33,6 +35,7 @@ foreach func: optional_libc_funcs
endif
endforeach
+dep_libsystemd = dependency('libsystemd', required: false)
dep_scanner = dependency('wayland-scanner', native: true)
prog_scanner = find_program(dep_scanner.get_pkgconfig_variable('wayland_scanner'))
dep_wp = dependency('wayland-protocols', version: '>= 1.12')
@@ -101,6 +104,17 @@ srcs_agl_compositor = [
xdg_shell_protocol_c,
]
+if dep_libsystemd.found()
+ config_h.set('HAVE_SYSTEMD', 1)
+
+ srcs_agl_compositor += 'src/systemd-notify.c'
+ deps_libweston += dep_libsystemd
+
+ message('Found systemd, enabling notify support')
+endif
+
+configure_file(output: 'config.h', configuration: config_h)
+
exe_agl_compositor = executable(
'agl-compositor',
srcs_agl_compositor,