summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorMarius Vlad <marius.vlad@collabora.com>2024-11-18 14:18:22 +0200
committerMarius Vlad <marius.vlad@collabora.com>2024-11-25 21:12:49 +0200
commitde6dfd292a1c55f8e275d301607eadc228aecb90 (patch)
treeee1ed8921889a6301908fcbf0b38150b2c442f23 /meson.build
parent2487a385711e0d1ec6a148e26b07791bf6442f96 (diff)
compositor: Add support for loading PipeWire backend
Bug-AGL: SPEC-5289 Signed-off-by: Marius Vlad <marius.vlad@collabora.com> Change-Id: I4a19aa6d242154db398578e2bdff452f713d7116
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index b17afa4..5cb16d6 100644
--- a/meson.build
+++ b/meson.build
@@ -169,16 +169,19 @@ if libweston_dep.found()
dir_path_x11_backend = join_paths(prefix_path, 'include', libweston_version, 'libweston', 'backend-x11.h')
dir_path_wayland_backend = join_paths(prefix_path, 'include', libweston_version, 'libweston', 'backend-wayland.h')
dir_path_rdp_backend = join_paths(prefix_path, 'include', libweston_version, 'libweston', 'backend-rdp.h')
+ dir_path_pipewire_backend = join_paths(prefix_path, 'include', libweston_version, 'libweston', 'backend-pipewire.h')
else
dir_path_x11_backend = join_paths(libweston_version, 'libweston', 'backend-x11.h')
dir_path_wayland_backend = join_paths(libweston_version, 'libweston', 'backend-wayland.h')
dir_path_rdp_backend = join_paths(libweston_version, 'libweston', 'backend-rdp.h')
+ dir_path_pipewire_backend = join_paths(libweston_version, 'libweston', 'backend-pipewire.h')
endif
else
message('Building with cross environment')
dir_path_x11_backend = join_paths(libweston_version, 'libweston', 'backend-x11.h')
dir_path_wayland_backend = join_paths(libweston_version, 'libweston', 'backend-wayland.h')
dir_path_rdp_backend = join_paths(libweston_version, 'libweston', 'backend-rdp.h')
+ dir_path_pipewire_backend = join_paths(libweston_version, 'libweston', 'backend-pipewire.h')
endif
# do the test
@@ -196,6 +199,10 @@ if libweston_dep.found()
config_h.set('HAVE_BACKEND_RDP', 1)
message('Building with RDP backend')
endif
+ if cc.has_header(dir_path_pipewire_backend)
+ config_h.set('HAVE_BACKEND_PIPEWIRE', 1)
+ message('Building with PipeWire backend')
+ endif
endif
if dep_libsystemd.found()