summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorMarius Vlad <marius.vlad@collabora.com>2024-11-13 11:09:14 +0200
committerMarius Vlad <marius.vlad@collabora.com>2024-11-25 21:09:49 +0200
commitf2ebad30021414ae4a1c1b67f811bef0d9893993 (patch)
tree817ed733289ee55b7ca52342357452fad131a6d2 /meson.build
parentd60ccb86d2e4cf75f7b9c6ef30fcdba9dae9ffe8 (diff)
compositor: Remove agl-shell-desktop extension
This has been for some time now in the making so let's remove it as we have gRPC proxy for some time now. Bug-AGL: SPEC-4672 Signed-off-by: Marius Vlad <marius.vlad@collabora.com> Change-Id: I2cb627cb30ef7756239779c70d9d9d2e317afed0
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 1 insertions, 5 deletions
diff --git a/meson.build b/meson.build
index aa811ad..b17afa4 100644
--- a/meson.build
+++ b/meson.build
@@ -64,14 +64,12 @@ foreach depname : depnames
endforeach
agl_shell_xml = files('protocol/agl-shell.xml')
-agl_shell_desktop_xml = files('protocol/agl-shell-desktop.xml')
xdg_shell_xml = join_paths(dir_wp_base, 'stable', 'xdg-shell', 'xdg-shell.xml')
dep_libweston_protocols = dependency('libweston-13-protocols', version: '>= 13')
dir_protocol_libweston = dep_libweston_protocols.get_pkgconfig_variable('pkgdatadir')
protocols = [
{ 'name': 'agl-shell', 'source': 'internal' },
- { 'name': 'agl-shell-desktop', 'source': 'internal' },
{ 'name': 'xdg-shell', 'source': 'wp-stable' },
{ 'name': 'xdg-output', 'source': 'unstable', 'version': 'v1' },
{ 'name': 'weston-output-capture', 'source': 'libweston-protocols' },
@@ -144,9 +142,7 @@ srcs_agl_compositor = [
'shared/os-compatibility.c',
'shared/process-util.c',
agl_shell_server_protocol_h,
- agl_shell_desktop_server_protocol_h,
agl_shell_protocol_c,
- agl_shell_desktop_protocol_c,
xdg_shell_protocol_c,
]
@@ -266,7 +262,7 @@ pkgconfig.generate(
)
install_data(
- [ agl_shell_xml, agl_shell_desktop_xml ],
+ [ agl_shell_xml ],
install_dir: join_paths(dir_data, dir_data_agl_compositor)
)