summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2021-02-24 17:09:40 -0500
committerScott Murray <scott.murray@konsulko.com>2022-03-29 15:41:54 -0400
commit4bd77c11f14157259b8d15bddcee28ddb6e8041c (patch)
treedefd6687d269216e778070d3e229e15940256388 /meson.build
parente4226be8727e4f8e19292b6d1d19a9ba2bcdd58d (diff)
Weston 9.0 compatibility changes
Changes: - Bump libweston dependencies in meson.build - Match weston_compositor_tear_down -> weston_compositor_destroy API change by following what was done in weston for 9.0 - Update log context code to match API changes, based on what was done in weston for 9.0 - Update transform names to match weston - Initialize a couple of structure fields to avoid failure from -Werror=missing-field-initializers triggered by changes in newer wayland. Bug-AGL: SPEC-3819 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I48fab590eb59a1b83b0cebc3762ba730450b0e3a
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 218779d..17913d0 100644
--- a/meson.build
+++ b/meson.build
@@ -10,7 +10,7 @@ project('agl-compositor',
)
config_h = configuration_data()
-libweston_version = 'libweston-8'
+libweston_version = 'libweston-9'
pkgconfig = import('pkgconfig')
fs = import('fs')
@@ -157,7 +157,7 @@ libweston_dep = dependency(libweston_version)
deps_libweston = [
dependency('wayland-server'),
libweston_dep,
- dependency('libweston-desktop-8'),
+ dependency('libweston-desktop-9'),
local_dep,
]