summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-02-05 17:07:34 -0500
committerScott Murray <scott.murray@konsulko.com>2022-03-29 15:41:56 -0400
commita02c5606aa6621c9d3e0cc968180e7993201e2da (patch)
treed4d907d9bbd3fa15bf1f0a9adba4fac95abdcd32 /meson.build
parent4bd77c11f14157259b8d15bddcee28ddb6e8041c (diff)
Weston 10.0 compatibility changes
Changes: - Bump libweston dependencies in meson.build. - Handle addition of another argument to the wet_main and weston_compositor_create functions. Bug-AGL: SPEC-3819 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 17913d0..5f6c29d 100644
--- a/meson.build
+++ b/meson.build
@@ -10,7 +10,7 @@ project('agl-compositor',
)
config_h = configuration_data()
-libweston_version = 'libweston-9'
+libweston_version = 'libweston-10'
pkgconfig = import('pkgconfig')
fs = import('fs')
@@ -157,7 +157,7 @@ libweston_dep = dependency(libweston_version)
deps_libweston = [
dependency('wayland-server'),
libweston_dep,
- dependency('libweston-desktop-9'),
+ dependency('libweston-desktop-10'),
local_dep,
]