summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 9 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index fc87e20..0357b29 100644
--- a/meson.build
+++ b/meson.build
@@ -169,14 +169,17 @@ if libweston_dep.found()
if not prefix_path.contains('/usr')
dir_path_x11_backend = join_paths(prefix_path, 'include', libweston_version, 'libweston', 'backend-x11.h')
dir_path_headless_backend = join_paths(prefix_path, 'include', libweston_version, 'libweston', 'backend-headless.h')
+ dir_path_rdp_backend = join_paths(prefix_path, 'include', libweston_version, 'libweston', 'backend-rdp.h')
else
dir_path_x11_backend = join_paths(libweston_version, 'libweston', 'backend-x11.h')
- dir_path_x11_backend = join_paths(libweston_version, 'libweston', 'backend-headless.h')
+ dir_path_headless_backend = join_paths(libweston_version, 'libweston', 'backend-headless.h')
+ dir_path_rdp = join_paths(libweston_version, 'libweston', 'backend-rdp.h')
endif
else
message('Building with cross environment')
dir_path_x11_backend = join_paths(libweston_version, 'libweston', 'backend-x11.h')
dir_path_headless_backend = join_paths(libweston_version, 'libweston', 'backend-headless.h')
+ dir_path_rdp_backend = join_paths(libweston_version, 'libweston', 'backend-rdp.h')
endif
# do the test
@@ -189,6 +192,11 @@ if libweston_dep.found()
config_h.set('HAVE_BACKEND_HEADLESS', 1)
message('Building with headless backend')
endif
+
+ if cc.has_header(dir_path_rdp_backend)
+ config_h.set('HAVE_BACKEND_RDP', 1)
+ message('Building with RDP backend')
+ endif
endif
if dep_libsystemd.found()