summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build25
1 files changed, 24 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index ab4f086..34f8558 100644
--- a/meson.build
+++ b/meson.build
@@ -59,10 +59,28 @@ foreach depname : depnames
if not dep.found()
message('Remoting requires @0@ which was not found. '.format(depname))
endif
-deps_remoting += dep
+ deps_remoting += dep
endforeach
+# the transmitter plug-in requires waltham but we don't have a cflags or libs
+# for it so we add waltham depends here. Further more, the output is being
+# handled by remoting plug-in
+depnames_waltham = [
+ 'waltham'
+]
+
+deps_waltham = []
+foreach depname : depnames_waltham
+ dep = dependency(depname, required: false)
+ if not dep.found()
+ message('Waltham requires @0@ which was not found. '.format(depname))
+ endif
+ deps_waltham += dep
+endforeach
+
+deps_waltham += deps_remoting
+
agl_shell_xml = files('protocol/agl-shell.xml')
agl_shell_desktop_xml = files('protocol/agl-shell-desktop.xml')
agl_screenshooter = files('protocol/agl-screenshooter.xml')
@@ -197,6 +215,11 @@ if deps_remoting.length() == depnames.length()
message('Found remoting depends, enabling remoting')
endif
+if deps_waltham.length() == depnames_waltham.length() + depnames.length()
+ config_h.set('HAVE_WALTHAM', 1)
+ message('Found waltham depends, enabling waltham')
+endif
+
if dep_libsmack.found()
config_h.set('HAVE_SMACK', 1)
deps_libweston += dep_libsmack