summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorMarius Vlad <marius.vlad@collabora.com>2022-10-27 16:39:37 +0300
committerMarius Vlad <marius.vlad@collabora.com>2022-10-27 17:25:22 +0300
commit4ccd64899f0219eb8940382467ca88da44f27a1d (patch)
tree9cc0d053b6b42fc230640d8aef2bb5eb226d418f /meson.build
parentdcb11eebdba956e567c7421b0511a6e6f0298931 (diff)
src: Re-work actions and provide a callback
This re-works a bit the way we handle events, and allows to pass a callback to the client directly. This patch further cleans-up the older agl-shell-desktop implementation and adds a a new action, 'deactivate' request as another example. Further more, clients can now choose to just listen for events, or listen for events and perform an action (activate). Bug-AGL: SPEC-4503 Signed-off-by: Marius Vlad <marius.vlad@collabora.com> Change-Id: Ic9f8bb1f6ff1c7f6b69f2059caac066ee106beba
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 2 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 321f130..bd00929 100644
--- a/meson.build
+++ b/meson.build
@@ -3,7 +3,8 @@ project('agl-shell-activator',
version: '0.0.2',
default_options: [
'warning_level=3',
- 'c_std=gnu99',
+ 'c_std=c2x',
+ 'cpp_std=c++20'
],
meson_version: '>= 0.60',
license: 'MIT/Expat',
@@ -63,8 +64,6 @@ srcs_agl_activator = [
'src/AglShellGrpcClient.h',
generated_protoc_sources,
generated_grpc_sources,
- agl_shell_desktop_client_protocol_h,
- agl_shell_desktop_protocol_c,
]
exe_wth_receiver = executable(