summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2016-03-31 17:56:32 +0200
committerJosé Bollo <jose.bollo@iot.bzh>2016-03-31 17:56:32 +0200
commit1205c90cccd3144bab24b4b5fd8dcbf0d0e6b570 (patch)
treeed8b93e852f4f7e6b1884348891e39b562eb74bb /CMakeLists.txt
parentcc4b56b6710624c069642d1a510d0060949fe5b9 (diff)
refactoring (in progress, tbf)
Change-Id: I8f2684a38d0894d827510d9a171ee6d5c39fb55e Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 58f82406..d1780784 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -18,10 +18,11 @@ INCLUDE(GNUInstallDirs)
add_compile_options(-Wall -Wextra -Wconversion)
add_compile_options(-Wno-unused-parameter) # frankly not using a parameter does it care?
add_compile_options(-Werror=maybe-uninitialized)
-#add_compile_options(-Werror=implicit-function-declaration)
+add_compile_options(-Werror=implicit-function-declaration)
add_compile_options(-ffunction-sections -fdata-sections)
add_compile_options(-Wl,--gc-sections)
add_compile_options(-fPIC)
+add_compile_options(-g)
set(CMAKE_C_FLAGS_PROFILING "-g -O2 -pg -Wp,-U_FORTIFY_SOURCE")
set(CMAKE_C_FLAGS_DEBUG "-g -O2 -ggdb -Wp,-U_FORTIFY_SOURCE")