summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFulup Ar Foll <fulup@iot.bzh>2016-05-29 23:41:40 +0200
committerFulup Ar Foll <fulup@iot.bzh>2016-05-29 23:41:40 +0200
commit26bca5f8a8c6f9403a84945a5cd914b6da948efd (patch)
tree88469dc3eaa063b3d773d5221fe3cb67e9b04cc0 /CMakeLists.txt
parent706bc5c7e0db5f7a782f80ab99fa8fe005289f8d (diff)
parent2ea7ffb3abc8c62cfd5235ba4dbcd040f0235d69 (diff)
Merge branch 'master' of https://github.com/iotbzh/afb-daemon
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c5094bb8..7a1a0d01 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,6 +10,9 @@ SET(PROJECT_DESCRIPTION "Secured binder of API for clients of the Application fr
SET(PROJECT_VERSION "0.5")
SET(PROJECT_URL "https://github.com/iotbzh/afb-daemon")
+SET(LIBAFBWSC_VERSION "0.5")
+SET(LIBAFBWSC_SOVERSION "0")
+
INCLUDE(FindPkgConfig)
INCLUDE(CheckIncludeFiles)
INCLUDE(CheckLibraryExists)
@@ -69,11 +72,11 @@ ADD_SUBDIRECTORY(plugins)
############################################################
# installs the pkgconfig files
CONFIGURE_FILE(afb-daemon.pc.in afb-daemon.pc @ONLY)
-CONFIGURE_FILE(afb-wsc.pc.in afb-wsc.pc @ONLY)
+CONFIGURE_FILE(libafbwsc.pc.in libafbwsc.pc @ONLY)
INSTALL(FILES
${CMAKE_CURRENT_BINARY_DIR}/afb-daemon.pc
- ${CMAKE_CURRENT_BINARY_DIR}/afb-wsc.pc
+ ${CMAKE_CURRENT_BINARY_DIR}/libafbwsc.pc
DESTINATION
${CMAKE_INSTALL_LIBDIR}/pkgconfig
)