summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2019-04-30 22:18:08 +0200
committerJosé Bollo <jose.bollo@iot.bzh>2019-04-30 22:18:08 +0200
commitd00bfe9410cfcaeb247ba68a88144defb5184ac9 (patch)
tree58e4a07e9d7ebad3215122449dc43193078c5ded /CMakeLists.txt
parent5214323d82cc09b15c25e348707f2639977ea763 (diff)
Allow to tune installation directories
The location of intrinsic bindings and samples could not be tuned but was fixed to be ${CMAKE_INSTALL_FULL_LIBDIR}/afb and ${CMAKE_INSTALL_FULL_DATADIR}/af-binder These default locations are not bad but it is important to be able to tune that location. Bug-AGL: SPEC-2367 Change-Id: I4d4f9e9490d61e3278ef35ac42f2143a752a7c37 Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ebda48f0..3962da28 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -51,6 +51,8 @@ set(AFS_SUPERVISION_SOCKET "@urn:AGL:afs:supervision:socket" CACHE STRING "Inter
set(AFS_SUPERVISOR_PORT 1619 CACHE STRING "Port of service for the supervisor")
set(AFS_SUPERVISOR_TOKEN HELLO CACHE STRING "Secret token for the supervisor")
set(UNITDIR_SYSTEM ${CMAKE_INSTALL_LIBDIR}/systemd/system CACHE STRING "Path to systemd system unit files")
+set(INTRINSIC_BINDING_DIR ${CMAKE_INSTALL_FULL_LIBDIR}/afb CACHE STRING "Path to install intrinsic bindings")
+set(SAMPLE_INSTALL_DIR ${CMAKE_INSTALL_FULL_DATADIR}/af-binder CACHE STRING "Path to install samples")
###########################################################################
@@ -156,8 +158,6 @@ ADD_SUBDIRECTORY(src/devtools)
IF(ONLY_DEVTOOLS)
MESSAGE(WARNING "Only DEVTOOLS are compiled, not the binder!")
ELSE()
- SET(binding_install_dir ${CMAKE_INSTALL_FULL_LIBDIR}/afb)
- SET(install_datadir ${CMAKE_INSTALL_FULL_DATADIR}/af-binder)
###########################################################################
# activates the monitoring by default
@@ -166,7 +166,7 @@ ELSE()
INSTALL(DIRECTORY
${CMAKE_CURRENT_SOURCE_DIR}/test/monitoring
DESTINATION
- ${binding_install_dir}
+ ${INTRINSIC_BINDING_DIR}
)
endif()