aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2016-05-19 15:40:29 +0200
committerJosé Bollo <jose.bollo@iot.bzh>2016-05-19 15:40:29 +0200
commitae7f9ff4ba5f58c90cd0b9f4ed17978b66a9c0b2 (patch)
tree06da89d8752411b52d4f2a036351aae7ef3287d3 /CMakeLists.txt
parenta2500c271b3837a55cf2166bfcc212993875ea63 (diff)
improves compatibility with yocto
Change-Id: I6458dd1e66b96c564d67304fc8f193772914499b Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 3 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 373a60e0..fcd376c8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -61,10 +61,9 @@ SET(link_libraries
${json-c_LIBRARIES}
)
-SET(plugin_install_dir ${CMAKE_INSTALL_LIBDIR}/afb)
-SET(plugin_full_install_dir ${CMAKE_INSTALL_PREFIX}/${plugin_install_dir})
+SET(plugin_install_dir ${CMAKE_INSTALL_FULL_LIBDIR}/afb)
-ADD_DEFINITIONS(-DPLUGIN_INSTALL_DIR="${plugin_full_install_dir}")
+ADD_DEFINITIONS(-DPLUGIN_INSTALL_DIR="${plugin_install_dir}")
ADD_SUBDIRECTORY(src)
ADD_SUBDIRECTORY(include)
@@ -77,6 +76,6 @@ CONFIGURE_FILE(afb-daemon.pc.in afb-daemon.pc @ONLY)
INSTALL(FILES
${CMAKE_CURRENT_BINARY_DIR}/afb-daemon.pc
DESTINATION
- ${CMAKE_INSTALL_FULL_LIBDIR}/pkgconfig
+ ${CMAKE_INSTALL_LIBDIR}/pkgconfig
)