aboutsummaryrefslogtreecommitdiffstats
path: root/bindings/intrinsics/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2019-04-30 22:18:08 +0200
committerJosé Bollo <jose.bollo@iot.bzh>2019-04-30 22:18:08 +0200
commitd00bfe9410cfcaeb247ba68a88144defb5184ac9 (patch)
tree58e4a07e9d7ebad3215122449dc43193078c5ded /bindings/intrinsics/CMakeLists.txt
parent5214323d82cc09b15c25e348707f2639977ea763 (diff)
Allow to tune installation directories
The location of intrinsic bindings and samples could not be tuned but was fixed to be ${CMAKE_INSTALL_FULL_LIBDIR}/afb and ${CMAKE_INSTALL_FULL_DATADIR}/af-binder These default locations are not bad but it is important to be able to tune that location. Bug-AGL: SPEC-2367 Change-Id: I4d4f9e9490d61e3278ef35ac42f2143a752a7c37 Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'bindings/intrinsics/CMakeLists.txt')
-rw-r--r--bindings/intrinsics/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/bindings/intrinsics/CMakeLists.txt b/bindings/intrinsics/CMakeLists.txt
index ee981217..b7668ce8 100644
--- a/bindings/intrinsics/CMakeLists.txt
+++ b/bindings/intrinsics/CMakeLists.txt
@@ -29,5 +29,5 @@ SET_TARGET_PROPERTIES(afb-dbus-binding PROPERTIES
)
TARGET_LINK_LIBRARIES(afb-dbus-binding ${json-c_LDFLAGS} ${libsystemd_LDFLAGS})
INSTALL(TARGETS afb-dbus-binding
- LIBRARY DESTINATION ${binding_install_dir})
+ LIBRARY DESTINATION ${INTRINSIC_BINDING_DIR})