summaryrefslogtreecommitdiffstats
path: root/bindings/tutorial/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2017-06-11 17:23:10 +0200
committerJosé Bollo <jose.bollo@iot.bzh>2017-10-09 14:08:29 +0200
commit70fe993324e901254c3e42225f9e5f5d111b1b14 (patch)
tree76a47195fafdbfbb9f583a5576638b29a8e0c258 /bindings/tutorial/CMakeLists.txt
parent86134053455a621eac709d2a2d766b80b7ba7ec7 (diff)
Add C++ interface
Change-Id: I05e104e4733d071949723073d32b21c22089ecdf Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'bindings/tutorial/CMakeLists.txt')
-rw-r--r--bindings/tutorial/CMakeLists.txt10
1 files changed, 6 insertions, 4 deletions
diff --git a/bindings/tutorial/CMakeLists.txt b/bindings/tutorial/CMakeLists.txt
index 844e2dfb..62775f2c 100644
--- a/bindings/tutorial/CMakeLists.txt
+++ b/bindings/tutorial/CMakeLists.txt
@@ -19,8 +19,8 @@
#INCLUDE_DIRECTORIES(${include_dirs})
-MACRO(tuto num)
- ADD_LIBRARY(tuto-${num} MODULE tuto-${num}.c)
+MACRO(tuto num ext)
+ ADD_LIBRARY(tuto-${num} MODULE tuto-${num}.${ext})
SET_TARGET_PROPERTIES(tuto-${num} PROPERTIES
PREFIX ""
LINK_FLAGS "-Wl,--version-script=${CMAKE_CURRENT_SOURCE_DIR}/export.map"
@@ -28,5 +28,7 @@ MACRO(tuto num)
TARGET_LINK_LIBRARIES(tuto-${num} ${link_libraries})
ENDMACRO(tuto)
-tuto(1)
-tuto(2)
+
+tuto(1 c)
+tuto(2 c)
+tuto(3 cpp)