summaryrefslogtreecommitdiffstats
path: root/plugins/CMakeLists.txt
diff options
context:
space:
mode:
authorManuel Bachmann <manuel.bachmann@iot.bzh>2015-12-21 06:57:05 +0100
committerManuel Bachmann <manuel.bachmann@iot.bzh>2015-12-21 07:00:46 +0100
commit98f5843474dcec55827279b6f42007341c171ae0 (patch)
tree010c6328cda7ef2b2577eb00ffca14c931dfbc3b /plugins/CMakeLists.txt
parent03bebc12f0fd5006a72e430084146a36d2db7c8d (diff)
Switch to a plugin model
Each API now compiles to a ".so" file, which gets searched for in the "${libdir}/afb" directory at startup. We can now load an arbitrary number of plugins (> 10). Signed-off-by: Manuel Bachmann <manuel.bachmann@iot.bzh>
Diffstat (limited to 'plugins/CMakeLists.txt')
-rw-r--r--plugins/CMakeLists.txt18
1 files changed, 4 insertions, 14 deletions
diff --git a/plugins/CMakeLists.txt b/plugins/CMakeLists.txt
index 7e3e0807..c66de5e7 100644
--- a/plugins/CMakeLists.txt
+++ b/plugins/CMakeLists.txt
@@ -1,14 +1,4 @@
-SET(SESSION_PLUGIN session/token-api.c)
-SET(HELLOWORLD_PLUGINS samples/HelloWorld.c)
-SET(SAMPLEPOST_PLUGINS samples/SamplePost.c)
-IF(alsa_FOUND)
- SET(AUDIO_PLUGIN audio/audio-api.c audio/audio-alsa.c)
-ENDIF(alsa_FOUND)
-IF(librtlsdr_FOUND)
- SET(RADIO_PLUGIN radio/radio-api.c radio/radio-rtlsdr.c)
-ENDIF(librtlsdr_FOUND)
-
-SET(PLUGINS_SOURCES ${SESSION_PLUGIN} ${HELLOWORLD_PLUGINS} ${SAMPLEPOST_PLUGINS} ${AUDIO_PLUGIN} ${RADIO_PLUGIN})
-
-ADD_LIBRARY(plugins OBJECT ${PLUGINS_SOURCES})
-INCLUDE_DIRECTORIES(${include_dirs})
+ADD_SUBDIRECTORY(session)
+ADD_SUBDIRECTORY(samples)
+ADD_SUBDIRECTORY(audio)
+ADD_SUBDIRECTORY(radio)