summaryrefslogtreecommitdiffstats
path: root/plugins/CMakeLists.txt
diff options
context:
space:
mode:
authorManuel Bachmann <manuel.bachmann@iot.bzh>2015-12-16 11:25:54 +0100
committerManuel Bachmann <manuel.bachmann@iot.bzh>2015-12-16 11:25:54 +0100
commite2d857c5f05f84de8e2642ff9272a80ea9e5fed6 (patch)
tree2df2f5939637de58a4fdad24b5cf0d5b9afd561f /plugins/CMakeLists.txt
parent4e43e3b53482bff8cb835271eb3207aeaf593812 (diff)
New tree organization, update CMake req. to 2.8.8.
Use CMake-2.8.8-specific feature to allow building the daemon from various source directories. Signed-off-by: Manuel Bachmann <manuel.bachmann@iot.bzh>
Diffstat (limited to 'plugins/CMakeLists.txt')
-rw-r--r--plugins/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/plugins/CMakeLists.txt b/plugins/CMakeLists.txt
new file mode 100644
index 00000000..269517ad
--- /dev/null
+++ b/plugins/CMakeLists.txt
@@ -0,0 +1,8 @@
+SET(PLUGINS_SOURCES audio/audio-api.c session/token-api.c)
+
+IF(librtlsdr_FOUND)
+ SET(PLUGINS_SOURCES ${PLUGINS_SOURCES} radio/radio-api.c)
+ENDIF(librtlsdr_FOUND)
+
+ADD_LIBRARY(plugins OBJECT ${PLUGINS_SOURCES})
+INCLUDE_DIRECTORIES(${include_dirs})