summaryrefslogtreecommitdiffstats
path: root/plugins/CMakeLists.txt
diff options
context:
space:
mode:
authorManuel Bachmann <manuel.bachmann@iot.bzh>2015-12-16 17:12:04 +0100
committerManuel Bachmann <manuel.bachmann@iot.bzh>2015-12-16 17:13:47 +0100
commit41c462374fb25fae29f3b4a28eb99fdb639e8547 (patch)
tree1d255970fbb1cf3a07d92d478a6261f7c16e08b9 /plugins/CMakeLists.txt
parentf4df9160115470439d1820409126694d138cd7be (diff)
Fix plugins loading, cleanup and dispatch Radio API code
Signed-off-by: Manuel Bachmann <manuel.bachmann@iot.bzh>
Diffstat (limited to 'plugins/CMakeLists.txt')
-rw-r--r--plugins/CMakeLists.txt9
1 files changed, 6 insertions, 3 deletions
diff --git a/plugins/CMakeLists.txt b/plugins/CMakeLists.txt
index 417321e4..0ddaf453 100644
--- a/plugins/CMakeLists.txt
+++ b/plugins/CMakeLists.txt
@@ -1,8 +1,11 @@
-SET(PLUGINS_SOURCES audio/audio-api.c session/token-api.c samples/HelloWorld.c)
-
+SET(AUDIO_PLUGIN audio/audio-api.c)
+SET(SESSION_PLUGIN session/token-api.c)
+SET(SAMPLE_PLUGINS samples/HelloWorld.c)
IF(librtlsdr_FOUND)
- SET(PLUGINS_SOURCES ${PLUGINS_SOURCES} radio/radio-api.c)
+ SET(RADIO_PLUGIN radio/radio-rtlsdr.c radio/radio-api.c)
ENDIF(librtlsdr_FOUND)
+SET(PLUGINS_SOURCES ${AUDIO_PLUGIN} ${SESSION_PLUGIN} ${RADIO_PLUGIN} ${SAMPLE_PLUGINS})
+
ADD_LIBRARY(plugins OBJECT ${PLUGINS_SOURCES})
INCLUDE_DIRECTORIES(${include_dirs})