summaryrefslogtreecommitdiffstats
path: root/plugins/afm-main-plugin/CMakeLists.txt
diff options
context:
space:
mode:
authorManuel Bachmann <manuel.bachmann@iot.bzh>2015-12-22 17:01:59 +0100
committerManuel Bachmann <manuel.bachmann@iot.bzh>2015-12-22 17:01:59 +0100
commit17ab342ea54c080a9fcf5f5a9b139e22de3e00dd (patch)
tree405a895377da7bc5f221c2b2f6efa4910ce2532c /plugins/afm-main-plugin/CMakeLists.txt
parent02492357cce066201a11993255120119c2703af1 (diff)
Centralize dependencies, add D-Bus dep. to README.md
README.md now mentions D-Bus. Checking dbus presence is now done at the same place as json-c, libmicrohttpdd... Signed-off-by: Manuel Bachmann <manuel.bachmann@iot.bzh>
Diffstat (limited to 'plugins/afm-main-plugin/CMakeLists.txt')
-rw-r--r--plugins/afm-main-plugin/CMakeLists.txt7
1 files changed, 0 insertions, 7 deletions
diff --git a/plugins/afm-main-plugin/CMakeLists.txt b/plugins/afm-main-plugin/CMakeLists.txt
index 673bc951..5ed1d4b2 100644
--- a/plugins/afm-main-plugin/CMakeLists.txt
+++ b/plugins/afm-main-plugin/CMakeLists.txt
@@ -1,14 +1,7 @@
-
-pkg_check_modules(EXTRAS REQUIRED dbus-1)
-add_compile_options(${EXTRAS_CFLAGS})
-include_directories(${EXTRAS_INCLUDE_DIRS})
-link_libraries(${EXTRAS_LIBRARIES})
-
ADD_LIBRARY(afm-main-api MODULE afm-main-plugin.c utils-jbus.c)
SET_TARGET_PROPERTIES(afm-main-api PROPERTIES PREFIX "")
TARGET_LINK_LIBRARIES(afm-main-api ${link_libraries})
INCLUDE_DIRECTORIES(${include_dirs})
INSTALL(TARGETS afm-main-api
LIBRARY DESTINATION ${plugin_install_dir})
-