summaryrefslogtreecommitdiffstats
path: root/plugins/audio/CMakeLists.txt
diff options
context:
space:
mode:
authorManuel Bachmann <manuel.bachmann@iot.bzh>2016-01-11 02:43:19 +0100
committerManuel Bachmann <manuel.bachmann@iot.bzh>2016-01-11 02:43:19 +0100
commitf16675ed24fd331903b8d6ef5d8ac07f6acbd6b0 (patch)
tree2852205153bdd62560f05eae05b899905942b376 /plugins/audio/CMakeLists.txt
parent14c6ab749e9ccfdde8d191c10e2d0426da53df1f (diff)
Audio Plugin: add PulseAudio support
If PulseAudio development libraries are present, Audio plugin will now support it. It may still fall back to ALSA if a PulseAudio server is not found at runtime. PulseAudio backend supports multiple clients using one audio adapter. (+ various fixes and style improvements) Signed-off-by: Manuel Bachmann <manuel.bachmann@iot.bzh>
Diffstat (limited to 'plugins/audio/CMakeLists.txt')
-rw-r--r--plugins/audio/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/plugins/audio/CMakeLists.txt b/plugins/audio/CMakeLists.txt
index 7fa1f75f..ee858b4c 100644
--- a/plugins/audio/CMakeLists.txt
+++ b/plugins/audio/CMakeLists.txt
@@ -1,6 +1,10 @@
IF(alsa_FOUND)
- ADD_LIBRARY(audio-api MODULE audio-api.c audio-alsa.c)
+ IF(pulseaudio_FOUND)
+ SET(pulse_sources audio-pulse.c)
+ ENDIF(pulseaudio_FOUND)
+
+ ADD_LIBRARY(audio-api MODULE audio-api.c audio-alsa.c ${pulse_sources})
SET_TARGET_PROPERTIES(audio-api PROPERTIES PREFIX "")
TARGET_LINK_LIBRARIES(audio-api ${link_libraries})
INCLUDE_DIRECTORIES(${include_dirs})