summaryrefslogtreecommitdiffstats
path: root/plugins/radio/CMakeLists.txt
diff options
context:
space:
mode:
authorManuel Bachmann <manuel.bachmann@iot.bzh>2016-05-23 16:39:52 +0200
committerManuel Bachmann <manuel.bachmann@iot.bzh>2016-05-23 16:39:52 +0200
commitbc54194e4d9ff8f25f7bbb1561b84bee074d8262 (patch)
tree2c5c614cd6c83e8f1548d69fae8d7109ec450069 /plugins/radio/CMakeLists.txt
parent83b48bb7331232020068d537716435458786a0cd (diff)
Fix Radio plugin linking, improve Radio code
Radio plugin now links correctly again (-lm was missing). Fix Radio plugin logic for new API, guard against some undefined values. Signed-off-by: Manuel Bachmann <manuel.bachmann@iot.bzh>
Diffstat (limited to 'plugins/radio/CMakeLists.txt')
-rw-r--r--plugins/radio/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/plugins/radio/CMakeLists.txt b/plugins/radio/CMakeLists.txt
index d86ca2b5..2aa765da 100644
--- a/plugins/radio/CMakeLists.txt
+++ b/plugins/radio/CMakeLists.txt
@@ -10,7 +10,7 @@ IF(librtlsdr_FOUND)
PREFIX ""
LINK_FLAGS "-Wl,--version-script=${CMAKE_CURRENT_SOURCE_DIR}/export.map"
)
- TARGET_LINK_LIBRARIES(radio-api ${link_libraries} ${librtlsdr_LIBRARIES})
+ TARGET_LINK_LIBRARIES(radio-api ${link_libraries} ${librtlsdr_LIBRARIES} -lm)
INSTALL(TARGETS radio-api
LIBRARY DESTINATION ${plugin_install_dir})