summaryrefslogtreecommitdiffstats
path: root/plugins/samples/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2016-05-24 12:28:39 +0200
committerJosé Bollo <jose.bollo@iot.bzh>2016-05-24 12:28:39 +0200
commit8cabf18f972606cd039db9a84366ef338446d12e (patch)
treec12051e0bf4df931db88a5c750711658fb62bfd2 /plugins/samples/CMakeLists.txt
parentbe4e0e2d3855ccbd3b683bfe6cc4c7f9d3254314 (diff)
adds the tic-tac-toe example
Change-Id: I9c52b2e4f17ad3f02e0ef64fdd78864b3761e0b2 Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'plugins/samples/CMakeLists.txt')
-rw-r--r--plugins/samples/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/plugins/samples/CMakeLists.txt b/plugins/samples/CMakeLists.txt
index 271fb850..9f600c82 100644
--- a/plugins/samples/CMakeLists.txt
+++ b/plugins/samples/CMakeLists.txt
@@ -27,3 +27,12 @@ SET_TARGET_PROPERTIES(clientCtx-api PROPERTIES
TARGET_LINK_LIBRARIES(clientCtx-api ${link_libraries})
INSTALL(TARGETS clientCtx-api
LIBRARY DESTINATION ${plugin_install_dir})
+
+ADD_LIBRARY(tic-tac-toe MODULE tic-tac-toe.c)
+SET_TARGET_PROPERTIES(tic-tac-toe PROPERTIES
+ PREFIX ""
+ LINK_FLAGS "-Wl,--version-script=${CMAKE_CURRENT_SOURCE_DIR}/export.map"
+)
+TARGET_LINK_LIBRARIES(tic-tac-toe ${link_libraries})
+INSTALL(TARGETS tic-tac-toe
+ LIBRARY DESTINATION ${plugin_install_dir})