summaryrefslogtreecommitdiffstats
path: root/plugins/samples/CMakeLists.txt
diff options
context:
space:
mode:
authorManuel Bachmann <manuel.bachmann@iot.bzh>2015-12-21 06:57:05 +0100
committerManuel Bachmann <manuel.bachmann@iot.bzh>2015-12-21 07:00:46 +0100
commit98f5843474dcec55827279b6f42007341c171ae0 (patch)
tree010c6328cda7ef2b2577eb00ffca14c931dfbc3b /plugins/samples/CMakeLists.txt
parent03bebc12f0fd5006a72e430084146a36d2db7c8d (diff)
Switch to a plugin model
Each API now compiles to a ".so" file, which gets searched for in the "${libdir}/afb" directory at startup. We can now load an arbitrary number of plugins (> 10). Signed-off-by: Manuel Bachmann <manuel.bachmann@iot.bzh>
Diffstat (limited to 'plugins/samples/CMakeLists.txt')
-rw-r--r--plugins/samples/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/plugins/samples/CMakeLists.txt b/plugins/samples/CMakeLists.txt
new file mode 100644
index 00000000..ef5b449e
--- /dev/null
+++ b/plugins/samples/CMakeLists.txt
@@ -0,0 +1,11 @@
+INCLUDE_DIRECTORIES(${include_dirs})
+
+ADD_LIBRARY(helloWorld-api MODULE HelloWorld.c)
+SET_TARGET_PROPERTIES(helloWorld-api PROPERTIES PREFIX "")
+INSTALL(TARGETS helloWorld-api
+ LIBRARY DESTINATION ${plugin_install_dir})
+
+ADD_LIBRARY(samplePost-api MODULE SamplePost.c)
+SET_TARGET_PROPERTIES(samplePost-api PROPERTIES PREFIX "")
+INSTALL(TARGETS samplePost-api
+ LIBRARY DESTINATION ${plugin_install_dir})