summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2018-07-05 17:17:35 +0200
committerJosé Bollo <jose.bollo@iot.bzh>2018-07-05 19:17:11 +0200
commit75526aa1e85a8bacb50e917971010d06137a3610 (patch)
tree33adc0e2410d8af36148a2901c0a20000e0cdaf5 /src/CMakeLists.txt
parent0d05349094ced7eeb487e572beb90fa44dd2ebe0 (diff)
supervision: Exclude conditionaly the supervision
Exclude from the binder the part related to the supervision when the supervisor is excluded from the build. Change-Id: I41193122d63e47b9f0db7f113f88d2d63b783027 Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index ed59ac0c..c457d235 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -54,7 +54,6 @@ SET(AFB_LIB_SOURCES
afb-proto-ws.c
afb-session.c
afb-stub-ws.c
- afb-supervision.c
afb-systemd.c
afb-trace.c
afb-websock.c
@@ -90,6 +89,10 @@ IF(INCLUDE_DBUS_TRANSPARENCY)
ADD_DEFINITIONS(-DWITH_DBUS_TRANSPARENCY)
SET(AFB_LIB_SOURCES ${AFB_LIB_SOURCES} afb-api-dbus.c)
ENDIF()
+IF(INCLUDE_SUPERVISOR)
+ ADD_DEFINITIONS(-DWITH_SUPERVISION)
+ SET(AFB_LIB_SOURCES ${AFB_LIB_SOURCES} afb-supervision.c)
+ENDIF()
ADD_LIBRARY(afb-lib STATIC ${AFB_LIB_SOURCES})