aboutsummaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJose Bollo <jose.bollo@iot.bzh>2018-11-22 09:03:33 +0100
committerJosé Bollo <jose.bollo@iot.bzh>2018-11-22 17:39:50 +0100
commitbc247d4c9e16e548c84466d8975529568e7c395d (patch)
tree757edd27e14a08b7122062febd01e34d425f41fd /src/CMakeLists.txt
parent153a7c9c44ac84f32a0869ed14e4f08563e6d97c (diff)
globset: Introduce globset for event handlingguppy_6.99.1guppy/6.99.16.99.1
It optimises the event handling that was slow. It also fix few bugs: - at most one event handler is called now - the handler call has the most specific pattern Change-Id: Ic13a0258b5743579ab15e0e953ec62206d982850 Signed-off-by: Jose Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 7038205c..e1a1073a 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -67,6 +67,7 @@ SET(AFB_LIB_SOURCES
fdev.c
fdev-epoll.c
fdev-systemd.c
+ globset.c
jobs.c
locale-root.c
pearson.c