aboutsummaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2016-06-13 16:36:51 +0200
committerJosé Bollo <jose.bollo@iot.bzh>2016-06-13 16:36:51 +0200
commit5b5a2e4412eea806451c016da9fb285bc09c17ab (patch)
treed6c9340bef28754483309b2a9095c24e69af6a9a /src/CMakeLists.txt
parent0a8f8f784646254d9b71e928e930003f82d89603 (diff)
Service instanciation
Adds the ability for a service to initiate calls to other services and to receive events in its own context. Change-Id: I5ff149a0231e551e9ce8a8de9658cb492a38cae1 Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 286b8254..6abc8736 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -42,6 +42,7 @@ ADD_LIBRARY(afb-lib STATIC
afb-method.c
afb-msg-json.c
afb-sig-handler.c
+ afb-svc.c
afb-subcall.c
afb-websock.c
afb-ws-client.c