aboutsummaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorRonan Le Martret <ronan.lemartret@iot.bzh>2017-05-19 16:58:14 +0200
committerRonan Le Martret <ronan.lemartret@iot.bzh>2017-05-19 17:09:21 +0200
commite000e3b73ee0582882324e504fe2dae7386534f8 (patch)
tree04ca7bff9a282587675935c1bd7bb81f39a740c3 /src/CMakeLists.txt
parent9eb56fc592c6e2c305a0fbcc69499271ac034236 (diff)
Fix cmake dependencydab_3.99.1dab/3.99.13.99.1
* update documentation (get libmicrohttpd>=0.9.54 from upstream). Change-Id: I361708fecd3b670dba0f32230fa3bcbd86fa9c55 Signed-off-by: Ronan Le Martret <ronan.lemartret@iot.bzh>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt15
1 files changed, 8 insertions, 7 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 11d9542b..0e39dc94 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -109,15 +109,16 @@ ADD_EXECUTABLE(afb-daemon main.c)
TARGET_LINK_LIBRARIES(afb-daemon
afb-lib
${link_libraries}
- ${libsystemd_LIBRARIES}
- ${libmicrohttpd_LIBRARIES}
- ${uuid_LIBRARIES}
- ${openssl_LIBRARIES}
- ${cynara_LIBRARIES}
+ ${libsystemd_LDFLAGS}
+ ${libmicrohttpd_LDFLAGS}
+ ${uuid_LDFLAGS}
+ ${openssl_LDFLAGS}
+ ${cynara_LDFLAGS}
-lmagic
-ldl
-lrt
)
+link_directories( /opt/libmicrohttpd-0.9.54/lib/ )
INSTALL(TARGETS afb-daemon
RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
@@ -129,7 +130,7 @@ SET_TARGET_PROPERTIES(afbwsc PROPERTIES
VERSION ${LIBAFBWSC_VERSION}
SOVERSION ${LIBAFBWSC_SOVERSION})
TARGET_LINK_LIBRARIES(afbwsc
- ${libsystemd_LIBRARIES}
+ ${libsystemd_LDFLAGS}
-Wl,--version-script=${CMAKE_CURRENT_SOURCE_DIR}/export-afbwsc.map
-Wl,--as-needed
-Wl,--gc-sections
@@ -144,7 +145,7 @@ ADD_EXECUTABLE(afb-client-demo afb-client-demo.c)
TARGET_LINK_LIBRARIES(afb-client-demo
afbwsc
${link_libraries}
- ${libsystemd_LIBRARIES}
+ ${libsystemd_LDFLAGS}
)
INSTALL(TARGETS afb-client-demo
RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})