aboutsummaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2017-03-22 16:49:53 +0100
committerJosé Bollo <jose.bollo@iot.bzh>2017-03-22 16:49:53 +0100
commitfeccdb76f572a5fad947475c21b5b9aff696b04b (patch)
tree8e70e3eefef68febe02b5447105fdc6d857426b7 /src/CMakeLists.txt
parentf5ce0df45f5ce9f0b57b250dfd44513d085f1e54 (diff)
Refactor of threading and signal monitor
The goal is to allow use of this facilities for things that are not 'afb_req'. Change-Id: I0d99c227934ed45136477bf6235bd1541d5f05cf Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 8d0121a5..6cbc6fa3 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -69,7 +69,6 @@ ADD_LIBRARY(afb-lib STATIC
afb-method.c
afb-msg-json.c
afb-session.c
- afb-sig-handler.c
afb-svc.c
afb-subcall.c
afb-thread.c
@@ -78,10 +77,12 @@ ADD_LIBRARY(afb-lib STATIC
afb-ws-json1.c
afb-ws.c
afb-wsj1.c
+ jobs.c
locale-root.c
+ sd-fds.c
+ sig-monitor.c
verbose.c
websock.c
- sd-fds.c
)
###########################################