summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2017-11-17 11:10:43 +0100
committerJosé Bollo <jose.bollo@iot.bzh>2017-11-17 11:58:13 +0100
commit8cbdf0a5cb4d9abf0684344a28746a21dfc36ac3 (patch)
treeeb84bacb00a38758234b62ee2bd2dac6dc71cbd4 /src/CMakeLists.txt
parent3a3ee2aa68333fce13fb2611b0165def47573c5d (diff)
CMAKE: allow to compile afb-genskel only
When missing components are detected, allows to not compile the binder if ALLOW_NO_BINDER is ON Change-Id: I0fb27844e3f36d4dd643bdf250f05b4f6769bc53 Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 68f1505a..d531ca2e 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -23,6 +23,10 @@ endif(CMAKE_C_COMPILER_VERSION VERSION_LESS 4.9)
INCLUDE(FindPkgConfig)
ADD_SUBDIRECTORY(genskel)
+
+IF(WITH_BINDER)
+###########################################
+
ADD_SUBDIRECTORY(tests)
ADD_DEFINITIONS(-DBINDING_INSTALL_DIR="${binding_install_dir}")
@@ -115,4 +119,7 @@ TARGET_LINK_LIBRARIES(afb-client-demo
INSTALL(TARGETS afb-client-demo
RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
-
+###########################################
+ELSE(WITH_BINDER)
+ MESSAGE(WARNING "NOT compiling the binder! but tools are compiled")
+ENDIF(WITH_BINDER)