aboutsummaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2017-07-27 15:55:45 +0200
committerJosé Bollo <jose.bollo@iot.bzh>2017-07-27 16:58:01 +0200
commit69a85a68b5883bd97eb662372acb68af137dda7f (patch)
treeb3fda676868682d467960318ac141f9d1c906d82 /src/CMakeLists.txt
parent4a3d0c568ec5ee1296f4a50f269a1eadc4898e27 (diff)
wrap-json: add unpacking tool for json
The functions wrap_json_unpack, wrap_json_vunpack, wrap_json_check, wrap_json_vcheck, wrap_json_match and wrap_json_vmatch can be used to get items in a json object. These functions are likely to be compatible in the format with the unpacking functions of the library jansson [1]. [1] http://jansson.readthedocs.io/en/2.10/apiref.html#parsing-and-validating-values Change-Id: I18ad702498b9a70215d88b2a3c13bd0f6194bb45 Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 7d2db4a5..6db4d4f2 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -69,6 +69,7 @@ ADD_LIBRARY(afb-lib STATIC
sig-monitor.c
verbose.c
websock.c
+ wrap-json.c
)
###########################################