aboutsummaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2017-07-06 10:59:14 +0200
committerJosé Bollo <jose.bollo@iot.bzh>2017-07-11 17:12:08 +0200
commitb2114e0f626ed42a5d6154c681486b4edb19fbbf (patch)
treea02b0da2fd69b4f990aaf08c01b9182519fe9d2f /src/CMakeLists.txt
parent846e952260278225b79de4062fff1f8f2145a544 (diff)
debug: Create a file indicating the waiting point
When AFB_DEBUG_WAIT is used, the file /tmp/afb-debug-<PID> is created and contains the name of the awaiting point (without tailing new line) Signals other than SIGINT are ignored when waiting for SIGINT. This improves the cleaning up. Example: the signal SIGTERM is delayed until after removal of the debugging indication file. Change-Id: I5c896e4d9a3a098affc18d4282e260d9bb253611 Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 31fcd519..7d2db4a5 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -28,6 +28,7 @@ ADD_SUBDIRECTORY(tests)
ADD_DEFINITIONS(-DBINDING_INSTALL_DIR="${binding_install_dir}")
# Always add INFER_EXTENSION (more details in afb-hreq.c)
ADD_DEFINITIONS(-DINFER_EXTENSION)
+ADD_DEFINITIONS(-DAGL_DEVEL)
ADD_LIBRARY(afb-lib STATIC
afb-api.c